Back to overview
Degraded

Ethereum: Increased Latency & Timeouts

Jan 22 at 05:37pm CET
Affected services
Ethereum

Resolved
Jan 22 at 07:00pm CET

At 17:30 CET we performed routine internal infrastructure upgrades which unexpectedly degraded several endpoints on the Ethereum chain.

We experienced increased latency and timeouts at some endpoints for ~34 minutes starting from approximately 17:37 CET.

Updated
Jan 22 at 06:11pm CET

The issues have now been fully resolved and we are actively monitoring all systems.

Updated
Jan 22 at 05:47pm CET

As of 17:37 CET, we’ve seen increased response times and error rates on our Ethereum API, affecting the following endpoints:

  • /:address/nft
  • /:address/nft/collections
  • /:address/nft
  • /wallets/:address/stats
  • /:address/nft/:token_address
  • /nft/:address/:token_id
  • /nft/:address/:token_id/stats

We’ve identified the cause and are working on a fix.

Created
Jan 22 at 05:37pm CET

We’re currently investigating increased response times and error rates on our Ethereum API.

Our team is currently investigating this as a high priority. We apologize for any inconvenience caused and will update you as soon as the issue is resolved.