Back to overview
Degraded

Increased latency/timeouts on the wallet history endpoint

May 06 at 01:33pm CEST
Affected services
Ethereum

Resolved
May 12 at 07:24am CEST

This issue should now be resolved and all services are restored to normal functionality.

Created
May 06 at 01:33pm CEST

We've noticed an increased in the latency and timeouts on the Wallet History endpoint. Our team is aware and investigating the issue. We’ll update you here as soon as we have more information.