Back to overview
Degraded
Polygon mainnet is stuck at block 74,592,238
Jul 30 at 02:00pm CEST
Affected services
Polygon
Polygon
Polygon
Resolved
Jul 30 at 07:44pm CEST
The network is now back in real time
Affected services
Created
Jul 30 at 02:00pm CEST
Due to the recent Heimdall v0.2.16 update, Polygon mainnet has become stuck at block 74,592,238. We are waiting for updates from the Matic Foundation.
Affected services