Back to overview
Degraded

Bsc and Sei are currently experiencing delays in real time data.

Mar 07, 2026 at 09:45am UTC
Affected services
BSC
BSC

Resolved
Mar 07, 2026 at 01:05pm UTC

The team has identified the issue and is pushing a fix now.

Created
Mar 07, 2026 at 09:45am UTC

We are seeing a delay in real-time data specifically for our Bsc and Sei chains. Our team is aware and investigating the issue. We'll post updates here as soon as we have more information.