Endpoint Degradation on EVM Chains
Resolved
Mar 27, 2026 at 08:43am UTC
All previously affected services are now back online.
Affected services
Updated
Mar 27, 2026 at 02:02am UTC
Our team has identified the issue and is actively pushing a fix.
Affected chains include: Ethereum, BSC, Polygon, Avalanche, Optimism, and Base.
Impacted endpoints include: wallet history, token prices, token balances, NFT data, and related endpoints.
We will update this page once the indexer has resumed and data is fully caught up.
Affected services
Created
Mar 27, 2026 at 01:15am UTC
We are currently experiencing an issue where data returned across multiple endpoints is stale. Our team is investigating the issue.
Affected services