Back to overview
Downtime
Partial API service downtime for our NFT endpoints.
May 8, 2026 at 1:14am UTC
Affected services
Ethereum
Chiliz
Resolved
May 8, 2026 at 10:41am UTC
The issue has been fully resolved now.
Affected services
Updated
May 8, 2026 at 7:27am UTC
The issue relates to an on going AWS incident https://health.aws.amazon.com/health/status
The team has made changes to minimize the and improve the timeouts in the meantime. We will push more updates soon.
Affected services
Created
May 8, 2026 at 1:14am UTC
We are currently investigating issues with NFT endpoint timeouts specifically affecting ETH and Chiliz chains only.
Affected services