Back to overview
Degraded

Increased data latency across the EVM chains.

Jun 05 at 03:50pm CEST
Affected services
Polygon
Fantom
Optimism
BSC

Resolved
Jun 05 at 06:01pm CEST

The issue has now been resolved, and the services are fully back online. The team will further investigate the root cause to ensure and prevent future downtime.

Created
Jun 05 at 03:50pm CEST

There is an increased latency of new data across some of our EVM Chains; the team is already aware and are working on restoring the affected services.