Back to overview
Degraded
Increased data latency across the EVM chains.
Jun 10 at 03:20pm CEST
Affected services
Polygon
Arbitrum
Fantom
Optimism
Base
Resolved
Jun 10 at 05:00pm CEST
The issue has now been resolved, and the services are fully back online. The team will further investigate the root cause to ensure and prevent future downtime.
Affected services
Polygon
Fantom
Arbitrum
Optimism
Base
Created
Jun 10 at 03:20pm CEST
There is an increased latency of new data across some of our EVM Chains; the team is already aware and are working on restoring the affected services.
Affected services
Polygon
Fantom
Arbitrum
Optimism
Base