Back to overview
Degraded
Increased data latency across EVM chains.
Jun 27 at 09:47am CEST
Affected services
Polygon
Arbitrum
Fantom
Cronos
Optimism
Resolved
Jun 27 at 11:23am CEST
The issue has been identified and the services have been fully restored. We will keep monitoring the system to ensure everything continues to be stable.
Affected services
Polygon
Fantom
Arbitrum
Cronos
Optimism
Created
Jun 27 at 09:47am CEST
There is an increased latency of new data across some of our EVM Chains; the team is already aware and are working on restoring the affected services.
Affected services
Polygon
Fantom
Arbitrum
Cronos
Optimism