Back to overview
Degraded

BSC related services (erc20 transfers, wallet history) are currently experiencing out of sync issues.

Jul 10, 2024 at 12:00pm UTC
Affected services
BSC

Resolved
Jul 11, 2024 at 7:15am UTC

We have identified the root cause and implemented a fix and the affected services are back online.

Created
Jul 10, 2024 at 12:00pm UTC

We have identified the root cause, and our team is working on a fix.