Back to overview
Degraded

Increased data latency on EVM chains

Jul 19 at 01:15pm CEST
Affected services
Ethereum
BSC
Polygon
Avalanche
Arbitrum
Fantom
Optimism
BSC Testnet

Resolved
Jul 19 at 02:39pm CEST

The fix has been applied and services should be online again. We will continue to monitor the system to ensure continued stability.

Created
Jul 19 at 01:15pm CEST

Some of our EVM chains experience increased latency for new data; the team is already aware and working to restore the affected services.