Binance Chain Performance Degradation
Resolved
Oct 10 at 04:28pm CEST
On October 9th, we experienced a delay in our Binance Chain indexer, which fluctuated between 5–60 minutes behind real-time data for a period of roughly 4 hours. The issue was caused by an unexpected spike in network activity, and our systems did not scale quickly enough to handle the load.
As of 17:00 CET on October 9th, we implemented measures to improve our automatic scaling during traffic surges. Since then, performance has been stable and real-time indexing has fully recovered.
We continue to closely monitor the network to ensure smooth operation. Thank you for your patience and understanding.
Affected services
Created
Oct 09 at 10:34am CEST
We’re currently experiencing delays on Binance Chain due to increased network activity and ongoing issues with our RPC node providers. Our team is working to restore normal performance as soon as possible.
Affected services