Back to overview
Degraded

Data APIs are currently experiencing delays in real time data.

Nov 19, 2025 at 9:28am UTC
Affected services
Ethereum
BSC
Polygon
Avalanche
Arbitrum
Fantom
Cronos
Optimism
Base
Gnosis
Chiliz
Ethereum Sepolia
BSC Testnet
Gnosis Testnet
Chiliz Testnet
Base Testnet

Resolved
Nov 19, 2025 at 11:06am UTC

All services are now running in real-time now.

Updated
Nov 19, 2025 at 10:15am UTC

We have identified the issue and a fix was deployed. The services are catching up to real time data now.

Created
Nov 19, 2025 at 9:28am UTC

We are seeing a delay in real-time data across all EVM chains. Our team is aware and investigating the issue. We'll post updates here as soon as we have more information.